Outage - South Reno

Incident Report for Net NV

Resolved

Power has been restored to the site and services are online. If you are still having issues please reach out to us by calling 775-453-4446.
Posted May 12, 2025 - 11:15 PDT

Investigating

We are currently investigating an outage in the South Reno area. The current estimated time to resolution is about 2 hours.
Posted May 12, 2025 - 10:25 PDT
This incident affected: Towers - (POPS) (Reno/Sparks).